summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD27
3 files changed, 25 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1ea76667417..d1df7a8504e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,10 +4,13 @@ pkgbase = python-blkinfo
pkgrel = 2
url = https://github.com/grinrag/blkinfo
arch = any
- license = GPL3
+ license = GPL-3.0-only
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = util-linux
- source = python-blkinfo::git+https://github.com/genalt/blkinfo#tag=0.2.0
+ source = python-blkinfo::git+https://github.com/grinrag/blkinfo#tag=0.2.0
sha256sums = SKIP
pkgname = python-blkinfo
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index e16177da2907..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,18 +0,0 @@
-*/
-.*.swp
-*.pkg.tar.xz
-src/
-pkg/
-*.tar
-*.tar.bz2
-*.tar.xz
-*.tar.gz
-*.tgz
-*.txz
-*.tbz
-*.tbz2
-*.zip
-*.run
-*.7z
-*.rar
-*.deb
diff --git a/PKGBUILD b/PKGBUILD
index f5cf30eb0663..97b678bc224f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,30 @@
-# Maintainer: atomicfs
+# Maintainer: atomicfs <https://aur.archlinux.org/account/atomicfs>
+
pkgname=python-blkinfo
pkgver=0.2.0
pkgrel=2
pkgdesc="A python library to list information about all available or the specified block devices"
arch=('any')
url="https://github.com/grinrag/blkinfo"
-license=('GPL3')
-depends=('python' 'util-linux')
-_pkgname=blkinfo
-source=("${pkgname}::git+https://github.com/genalt/${_pkgname}#tag=${pkgver}")
+license=('GPL-3.0-only')
+depends=(
+ 'python'
+ 'util-linux'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+)
+source=("${pkgname}::git+${url}#tag=${pkgver}")
sha256sums=('SKIP')
+build() {
+ cd "${srcdir}/${pkgname}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "${srcdir}/${pkgname}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "${srcdir}/${pkgname}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}