summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d090476d55d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-catkin_lint
+ pkgdesc = Check catkin packages for common errors
+ pkgver = 1.4.16
+ pkgrel = 1
+ url = https://github.com/fkie/catkin_lint
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-1.4.16.tar.gz
+ md5sums = 6252b8ac505cfc0a87d0064e316db460
+
+pkgname = python-catkin_lint
+ depends =
+ depends = python
+ depends = python-catkin_pkg
+
+pkgname = python2-catkin_lint
+ depends =
+ depends = python2
+ depends = python2-catkin_pkg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd167845fe1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
+
+pkgbase=('python-catkin_lint')
+pkgname=('python-catkin_lint' 'python2-catkin_lint')
+_module='catkin_lint'
+pkgver='1.4.16'
+pkgrel=1
+pkgdesc="Check catkin packages for common errors"
+url="https://github.com/fkie/catkin_lint"
+depends=()
+makedepends=('python-setuptools' 'python2-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/c/catkin_lint/catkin_lint-${pkgver}.tar.gz")
+md5sums=('6252b8ac505cfc0a87d0064e316db460')
+
+prepare() {
+ cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
+}
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-catkin_lint() {
+ depends+=('python' 'python-catkin_pkg')
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+package_python2-catkin_lint() {
+ depends+=('python2' 'python2-catkin_pkg')
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}