summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf82b63e3342
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-certbot-dns-netcup
+ pkgdesc = netcup DNS Authenticator plugin for Certbot
+ pkgver = 0.31.0.1
+ pkgrel = 1
+ url = https://github.com/coldfix/certbot-dns-netcup
+ arch = any
+ license = Apache
+ license = License
+ license = 2.0
+ makedepends = python
+ makedepends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/c/certbot-dns-netcup/certbot-dns-netcup-0.31.0.1.tar.gz
+ sha256sums = 19693246ba8adc4550b18bb3cb00b9a4b2a0add737d76f62c1169cfc055293fc
+
+pkgname = python-certbot-dns-netcup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c87f2398769
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer:F43nd1r <support@faendir.com>
+# Python package author: Thomas Gläßle <thomas@coldfix.de>
+_name=certbot-dns-netcup
+pkgname=python-$_name
+pkgver=0.31.0.1
+pkgrel=1
+pkgdesc="netcup DNS Authenticator plugin for Certbot"
+arch=(any)
+url="https://github.com/coldfix/certbot-dns-netcup"
+license=(Apache License 2.0)
+makedepends=("python" "python-setuptools")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('19693246ba8adc4550b18bb3cb00b9a4b2a0add737d76f62c1169cfc055293fc')
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}