summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c437481a6ed..82045ec52b40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-cheetah3
pkgdesc = A Python 3-powered template engine and code generator
pkgver = 3.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.cheetahtemplate.org
arch = x86_64
license = custom
@@ -13,7 +13,7 @@ pkgbase = python-cheetah3
provides = python-cheetah3
conflicts = cheetah3
conflicts = python-cheetah3
- source = https://files.pythonhosted.org/packages/54/86/ea50bb5baf1daa8ca1a56774d48150a69376679d27c4130848702efc378c/Cheetah3-3.1.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/C/Cheetah3/Cheetah3-3.1.0.tar.gz
sha512sums = 879de1b7a333def757a1618b7c28348d8b2f43a433aa8d5d9ee501619a854c514ca4a842f741bf4d272f5cc2defa137b741d2cc9648a3fc40dc2c4ab50692fac
pkgname = python-cheetah3
diff --git a/PKGBUILD b/PKGBUILD
index d2be31c1cba4..932242032e92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Alex Brinister <alex_brinister -at- yahoo -dot- com>
pkgname=python-cheetah3
+_name=Cheetah3
pkgver=3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Python 3-powered template engine and code generator"
arch=(x86_64)
url="http://www.cheetahtemplate.org"
@@ -12,7 +13,7 @@ depends=(python)
makedepends=('python-setuptools' 'python-pygments' 'python-markdown')
provides=('cheetah3' 'python-cheetah3')
conflicts=('cheetah3' 'python-cheetah3')
-source=("https://files.pythonhosted.org/packages/54/86/ea50bb5baf1daa8ca1a56774d48150a69376679d27c4130848702efc378c/Cheetah3-${pkgver}.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha512sums=('879de1b7a333def757a1618b7c28348d8b2f43a433aa8d5d9ee501619a854c514ca4a842f741bf4d272f5cc2defa137b741d2cc9648a3fc40dc2c4ab50692fac')
build() {
@@ -22,9 +23,9 @@ build() {
package() {
msg "Install..."
- cd "${srcdir}/Cheetah3-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" || return 1
msg2 "Install copyright resources in /usr/share/licenses/${pkgname}..."
- install -Dm644 "${srcdir}/Cheetah3-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${_name}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}