summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba1fa1507309..95121ffdfbac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,8 @@ pkgbase = python-cmyt
depends = python-numpy
options = !emptydirs
source = https://pypi.io/packages/source/c/cmyt/cmyt-1.0.4.tar.gz
- sha256sums = 76b238eef0fbbbea810dda4821331a9b03f74e5e2dda9997e401c685deec1631
+ source = LICENSE
+ sha256sums = ae5157d37e733ae55df12bad1e8aedb3eb2f3b45e829e25c83df023dcefd5926
+ sha256sums = 6e13969520b08a454eed4e15bef8926babca14ab65f4f9936c9adc1860c00e1d
pkgname = python-cmyt
diff --git a/PKGBUILD b/PKGBUILD
index 151fb89a2b60..4a913878cd13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,16 +12,21 @@ depends=(python-colorspacious python-matplotlib python-more-itertools python-num
makedepends=()
optdepends=()
options=(!emptydirs)
-source=("https://pypi.io/packages/source/c/${_module_name}/${_module_name}-${pkgver}.tar.gz")
-sha256sums=('ae5157d37e733ae55df12bad1e8aedb3eb2f3b45e829e25c83df023dcefd5926')
+source=(
+ "https://pypi.io/packages/source/c/${_module_name}/${_module_name}-${pkgver}.tar.gz"
+ "LICENSE"
+)
+sha256sums=('ae5157d37e733ae55df12bad1e8aedb3eb2f3b45e829e25c83df023dcefd5926'
+ '6e13969520b08a454eed4e15bef8926babca14ab65f4f9936c9adc1860c00e1d')
build() {
cd "$srcdir/${_module_name}-$pkgver"
+ rm -rf tests/
python setup.py build
}
package() {
cd "$srcdir/${_module_name}-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}