summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59d18abf775a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-cmyt
+ pkgdesc = Matplotlib colormaps from the yt project!
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/yt-project/cmyt
+ arch = any
+ license = BSD
+ depends = python-colorspacious
+ depends = python-matplotlib
+ depends = python-more-itertools
+ depends = python-numpy
+ options = !emptydirs
+ source = https://pypi.io/packages/source/c/cmyt/cmyt-1.0.4.tar.gz
+ sha256sums = ae5157d37e733ae55df12bad1e8aedb3eb2f3b45e829e25c83df023dcefd5926
+
+pkgname = python-cmyt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..20255eb6875d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Original maintainer: Stuart Mumford <stuart@cadair.com>
+# Current maintainer: Corentin Cadiou <contact@cphyc.me>
+pkgname=python-cmyt
+_module_name=cmyt
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Matplotlib colormaps from the yt project!"
+arch=(any)
+url="https://github.com/yt-project/cmyt"
+license=('BSD')
+depends=('python-colorspacious' 'python-matplotlib' 'python-more-itertools' 'python-numpy')
+options=(!emptydirs)
+source=("https://pypi.io/packages/source/c/${_module_name}/${_module_name}-${pkgver}.tar.gz")
+sha256sums=('ae5157d37e733ae55df12bad1e8aedb3eb2f3b45e829e25c83df023dcefd5926')
+
+build() {
+ cd "$srcdir/${_module_name}-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_module_name}-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 COPYING.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: