summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36b78aafe07c..ff2d4770d76f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-colcon-package-information
pkgdesc = An extension for colcon-core to provide information about the packages.
- pkgver = 0.2.2
+ pkgver = 0.4.0
pkgrel = 1
url = https://pypi.org/project/colcon-package-information/
arch = any
license = Apache
makedepends = python-setuptools
+ makedepends = flake8
depends = python-colcon-core
- source = https://files.pythonhosted.org/packages/2d/34/3571034051350571b4c885258ddb9b600ddd6abcd8cf94799f314e97a961/colcon-package-information-0.2.2.tar.gz
- sha256sums = 4d34a0c05ca6c94679ef37b8166895f41343919de051bb884af8010c10afdcfa
+ source = https://github.com/colcon/colcon-package-information/archive/refs/tags/0.4.0.tar.gz
+ source = https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
+ sha256sums = 1ea7d25cb0ccafc8f7c7ab56e49aad27cf67c15091c3fad6418808c4d3ab6cd8
+ sha256sums = 04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082
pkgname = python-colcon-package-information
-
diff --git a/PKGBUILD b/PKGBUILD
index 0a147ae4cbdb..809e2346baf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,34 @@
-# Maintainer: Tong Chunli<t.cunly at 163 dot com>
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-package-information
-pkgver=0.2.2
+_name=${pkgname:7}
+pkgver=0.4.0
pkgrel=1
pkgdesc="An extension for colcon-core to provide information about the packages."
arch=(any)
url="https://pypi.org/project/colcon-package-information/"
license=('Apache')
depends=('python-colcon-core')
-makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/2d/34/3571034051350571b4c885258ddb9b600ddd6abcd8cf94799f314e97a961/colcon-package-information-0.2.2.tar.gz)
-sha256sums=('4d34a0c05ca6c94679ef37b8166895f41343919de051bb884af8010c10afdcfa')
+makedepends=('python-setuptools' 'flake8')
+source=(
+ https://github.com/colcon/colcon-package-information/archive/refs/tags/${pkgver}.tar.gz
+ https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz)
+sha256sums=('1ea7d25cb0ccafc8f7c7ab56e49aad27cf67c15091c3fad6418808c4d3ab6cd8'
+ '04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082')
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m build --wheel --no-isolation
+}
-package() {
- cd ${srcdir}/colcon-package-information-${pkgver}
+check() {
+ cd ${srcdir}/${_name}-${pkgver}/test
+ export PYTHONPATH="${srcdir}/scspell-2.2:${srcdir}/${_name}-${pkgver}"
+ ls test*.py | xargs -I {} pytest {}
+}
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+package() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}