summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 145fbec36737..54662987cff7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-colcon-ros
pkgdesc = An extension for colcon-core to support ROS packages.
- pkgver = 0.3.22
+ pkgver = 0.4.1
pkgrel = 1
url = https://pypi.org/project/colcon-ros/
arch = any
@@ -14,7 +14,9 @@ pkgbase = python-colcon-ros
depends = python-colcon-python-setup-py
depends = python-pyparsing
depends = python-catkin_pkg
- source = https://files.pythonhosted.org/packages/source/c/colcon-ros/colcon-ros-0.3.22.tar.gz
- sha256sums = c22124e018930427ae66faaa77777adddbb5e8d7790e60711f012b3a43ceda01
+ source = https://github.com/colcon/colcon-ros/archive/refs/tags/0.4.1.tar.gz
+ source = https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz
+ sha256sums = 17a4bb3191853e3b1287b2a541e532c321c83f75253c8e46c60f414c7abcdf02
+ sha256sums = 04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082
pkgname = python-colcon-ros
diff --git a/PKGBUILD b/PKGBUILD
index bf87a576a1cc..c53fd0408a15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tong Chunli<t.cunly at 163 dot com>
pkgname=python-colcon-ros
_name=${pkgname:7}
-pkgver=0.3.22
+pkgver=0.4.1
pkgrel=1
pkgdesc="An extension for colcon-core to support ROS packages."
arch=(any)
@@ -10,9 +10,23 @@ url="https://pypi.org/project/colcon-ros/"
license=('Apache')
depends=('python-colcon-core' 'python-colcon-library-path' 'python-colcon-cmake' 'python-colcon-pkg-config' 'python-colcon-recursive-crawl' 'python-colcon-python-setup-py' 'python-pyparsing' 'python-catkin_pkg')
makedepends=('python-setuptools')
-source=(https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz)
-sha256sums=('c22124e018930427ae66faaa77777adddbb5e8d7790e60711f012b3a43ceda01')
+source=(
+ https://github.com/colcon/colcon-ros/archive/refs/tags/${pkgver}.tar.gz
+ https://github.com/myint/scspell/archive/refs/tags/v2.2.tar.gz)
+sha256sums=(
+ '17a4bb3191853e3b1287b2a541e532c321c83f75253c8e46c60f414c7abcdf02'
+ '04c6a795a9e0ef4571678eb9fc503bcf39106a975691336af778f31a01027082')
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd ${srcdir}/${_name}-${pkgver}/test
+ export PYTHONPATH="${srcdir}/scspell-2.2:${srcdir}/${_name}-${pkgver}"
+ ls test*.py | xargs -I {} pytest {}
+}
package() {
cd ${srcdir}/${_name}-${pkgver}