summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD17
3 files changed, 39 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f96c96dd51..93fadd2d80d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-colored
pkgdesc = Very simple Python library for color and formatting in terminal
- pkgver = 1.4.2
+ pkgver = 2.2.4
pkgrel = 1
url = https://gitlab.com/dslackw/colored
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-flit
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- source = https://files.pythonhosted.org/packages/source/c/colored/colored-1.4.2.tar.gz
- sha256sums = 056fac09d9e39b34296e7618897ed1b8c274f98423770c2980d829fd670955ed
+ source = https://files.pythonhosted.org/packages/source/c/colored/colored-2.2.4.tar.gz
+ source = LICENSE
+ sha256sums = 595e1dd7f3b472ea5f12af21d2fec8a2ea2cf8f9d93e67180197330b26df9b61
+ sha256sums = 6e38bc085fb26b5aa0db7b77be9893a805cce0badb2c2950d2fd36626b9a8dd1
pkgname = python-colored
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e319bac41baa
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+MIT License
+
+Copyright 2014-2023 Dimitris Zlatanidis
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of
+this software and associated documentation files (the "Software"), to deal in
+the Software without restriction, including without limitation the rights to
+use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software is furnished to do so,
+subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS
+FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR
+COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 6439615de2a6..39b90c174aa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,27 @@
pkgname=python-colored
_name=${pkgname#python-}
-pkgver=1.4.2
+pkgver=2.2.4
pkgrel=1
pkgdesc="Very simple Python library for color and formatting in terminal"
arch=('any')
url="https://gitlab.com/dslackw/colored"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('056fac09d9e39b34296e7618897ed1b8c274f98423770c2980d829fd670955ed')
+makedepends=(python-build python-flit python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('595e1dd7f3b472ea5f12af21d2fec8a2ea2cf8f9d93e67180197330b26df9b61'
+ '6e38bc085fb26b5aa0db7b77be9893a805cce0badb2c2950d2fd36626b9a8dd1')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
cd $_name-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}