summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6969acaddac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-configfile
+ pkgdesc = Python library for dynamically parsing and editing configuration files with support for subsections.
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://kynikos.github.io/lib.py.configfile
+ arch = any
+ license = GPL3
+ depends = python
+ source = http://downloads.sourceforge.net/project/kynikos/lib.py.configfile/python-configfile-1.1.1.tar.bz2
+ sha256sums = b6178fc4377f1025f4b2526eeea02db93bb5560ee1ab27552c39348d03c6e99d
+
+pkgname = python-configfile
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..185bcd5f80fc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/python-configfile
+/*.pkg.tar.xz
+/*.src.tar.gz
+/*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19ac9ee67385
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='python-configfile'
+pkgver='1.1.1'
+pkgrel=1
+pkgdesc="Python library for dynamically parsing and editing configuration files with support for subsections."
+arch=('any')
+url="https://kynikos.github.io/lib.py.configfile"
+license=('GPL3')
+depends=('python')
+source=("http://downloads.sourceforge.net/project/kynikos/lib.py.configfile/$pkgname-$pkgver.tar.bz2")
+sha256sums=('b6178fc4377f1025f4b2526eeea02db93bb5560ee1ab27552c39348d03c6e99d')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}