summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d1d7b57c6db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-configize
+ pkgdesc = Load YAML configuration respecting XDG
+ pkgver = 1.0.1
+ pkgrel = 0
+ url = https://gitlab.com/aw1cks/python-configize
+ arch = any
+ license = AGPL3
+ depends = python>=3.6
+ depends = python-xdg
+ depends = python-yaml
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/C/Configize/Configize-1.0.1.tar.gz
+ sha256sums = 80e0961540153c6ac76b3e56f18e6955882ac5b7296f69e0c76bc2e0289b8317
+
+pkgname = python-configize
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4fdf053b935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alex Wicks <alex@awicks.io> (https://aur.archlinux.org/account/aw1cks)
+pkgname='python-configize'
+_name='Configize'
+pkgver=1.0.1
+pkgrel=0
+pkgdesc='Load YAML configuration respecting XDG'
+arch=(any)
+url="https://gitlab.com/aw1cks/${pkgname}"
+license=('AGPL3')
+groups=()
+depends=(
+ 'python>=3.6'
+ 'python-xdg'
+ 'python-yaml'
+)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-$pkgver.tar.gz")
+sha256sums=('80e0961540153c6ac76b3e56f18e6955882ac5b7296f69e0c76bc2e0289b8317')
+
+build() {
+ cd "${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_name}-${pkgver}"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}