summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..361aefe23bee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-configula
+ pkgdesc = creates config for papermerge-core
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/papermerge/configula
+ arch = any
+ license = Apache
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-poetry-core
+ depends = python-tomlkit
+ source = https://files.pythonhosted.org/packages/source/c/configula/configula-0.5.2.tar.gz
+ sha256sums = d293087a584ff94c48b96b9bb0b1ae9cbc61ed1efdacd6bf66ffd750c91d900a
+
+pkgname = python-configula
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28bf0b47e3bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Lex Black <autumn-wind@web.de>
+
+_module=configula
+pkgname=python-${_module}
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="creates config for papermerge-core"
+arch=(any)
+url="https://github.com/papermerge/configula"
+license=(Apache)
+depends=(python-tomlkit)
+makedepends=(python-build python-installer python-wheel python-poetry-core)
+source=(https://files.pythonhosted.org/packages/source/${_module::1}/$_module/${_module//-/_}-$pkgver.tar.gz)
+sha256sums=('d293087a584ff94c48b96b9bb0b1ae9cbc61ed1efdacd6bf66ffd750c91d900a')
+
+
+build() {
+ cd "${_module//-/_}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_module//-/_}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}