summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d568e62d706
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Jul 22 07:33:28 UTC 2019
+pkgbase = python-consonance-git
+ pkgdesc = implements WhatsApp's handshake process which makes use of Noise Pipes from Noise Protocol
+ pkgver = 0.1.3.r0.gabe1a20
+ pkgrel = 1
+ url = https://github.com/tgalal/consonance
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-transitions
+ depends = python-protobuf
+ depends = python-axolotl-curve25519
+ depends = python-dissononce
+ provides = python-consonance
+ source = python-consonance-git::git+https://github.com/tgalal/consonance
+ sha512sums = SKIP
+
+pkgname = python-consonance-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e137d926188
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname='python-consonance-git'
+pkgver=0.1.3.r0.gabe1a20
+pkgrel=1
+pkgdesc="implements WhatsApp's handshake process which makes use of Noise Pipes from Noise Protocol"
+url="https://github.com/tgalal/consonance"
+arch=('any')
+license=('GPL')
+depends=('python' 'python-transitions' 'python-protobuf' 'python-axolotl-curve25519' 'python-dissononce')
+makedepends=('python-setuptools')
+provides=('python-consonance')
+source=("${pkgname}::git+https://github.com/tgalal/consonance")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="$pkgdir/"
+}