summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b0f33be69da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-crcmod
+ pkgdesc = Cyclic Redundancy Check (CRC) implementation in Python.
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/crcmod/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/c/crcmod/crcmod-1.7.tar.gz
+ md5sums = 2d5b92117d958dcead94f9e17f54cd32
+
+pkgname = python-crcmod
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e53a7a8c878a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Your Name <youremail@domain.com>
+_pkgname=crcmod
+pkgname=python-crcmod
+pkgver=1.7
+pkgrel=1
+pkgdesc="Cyclic Redundancy Check (CRC) implementation in Python."
+arch=('i686' 'x86_64')
+url="https://pypi.python.org/pypi/crcmod/"
+license=('MIT')
+groups=()
+depends=('python')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://pypi.python.org/packages/source/c/$_pkgname/$_pkgname-${pkgver}.tar.gz")
+md5sums=(2d5b92117d958dcead94f9e17f54cd32)
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: