summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--changelog.txt24
3 files changed, 29 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b27449b3b24f..cc9cc9a890a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-cstruct
pkgdesc = C-style structs for Python
- pkgver = 5.0
+ pkgver = 5.2
pkgrel = 1
url = https://github.com/andreax79/python-cstruct
changelog = changelog.txt
@@ -12,7 +12,7 @@ pkgbase = python-cstruct
makedepends = python-installer
makedepends = python-wheel
depends = python
- source = python-cstruct-5.0.tar.gz::https://github.com/andreax79/python-cstruct/archive/v5.0.tar.gz
- sha256sums = 7e929b879b9ebdac49bce16e170499180a7273bf381393da27a46bcdefea3fc7
+ source = python-cstruct-5.2.tar.gz::https://github.com/andreax79/python-cstruct/archive/v5.2.tar.gz
+ sha256sums = 59ca9d53f95c032fb6ea45ce543d6ee83fe5716370b3e1dc6e0834688f710403
pkgname = python-cstruct
diff --git a/PKGBUILD b/PKGBUILD
index 1c923a46bae2..7791756788dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andrew Chen <xor.tux@gmail.com>
pkgname=python-cstruct
-pkgver=5.0
+pkgver=5.2
pkgrel=1
pkgdesc="C-style structs for Python"
url="https://github.com/andreax79/python-cstruct"
@@ -13,7 +13,7 @@ makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel
checkdepends=('python-pytest')
changelog=changelog.txt
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('7e929b879b9ebdac49bce16e170499180a7273bf381393da27a46bcdefea3fc7')
+sha256sums=('59ca9d53f95c032fb6ea45ce543d6ee83fe5716370b3e1dc6e0834688f710403')
build() {
cd "$pkgname-$pkgver"
diff --git a/changelog.txt b/changelog.txt
index a7a35c26afed..6aece759250c 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -190,3 +190,27 @@
- Documentation and examples
- Restructure setup
+
+## 5.1
+
+2022-11-20
+
+### Improved
+
+- Support unpack from ctype pointers
+
+### Added
+
+- Add support for char constants
+- Add native type test
+- dir.py example
+
+## 5.2
+
+2022-11-23
+
+### Fix
+
+- nested struct unpack fix
+- nested anonymous union offset fix
+- inspect offset for nested struct/union fix