summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
-rw-r--r--python2-dill.install10
3 files changed, 14 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03e9eee92266..d424c9de9adc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Jun 27 06:40:56 UTC 2019
pkgbase = python-dill
pkgdesc = Serialize all of python (almost)
- pkgver = 0.3.0
- pkgrel = 1
+ pkgver = 0.3.3
+ pkgrel = 2
url = http://pypi.python.org/pypi/dill/
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://github.com/uqfoundation/dill/archive/dill-0.3.0.tar.gz
- source = python2-dill.install
- md5sums = bf5c2ca7c8441fc6c8908fd316b7de2b
- md5sums = 2ac075f39bab33c203e7b25adb3e07b3
-
-pkgname = python-dill
depends = python
- optdepends = python-pyreadline
optdepends = python-objgraph
+ source = https://github.com/uqfoundation/dill/archive/dill-0.3.3.tar.gz
+ md5sums = 80e782f27a5198238c6b43d75acea68d
-pkgname = python2-dill
- install = python2-dill.install
- depends = python2
- optdepends = python2-pyreadline
- optdepends = python2-objgraph
+pkgname = python-dill
diff --git a/PKGBUILD b/PKGBUILD
index 0ed06a3534d4..e3c76569d149 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,23 @@
-# former Maintainer python-dill: Antony Lee
-# former Maintainer python2-dill: bchretien
-
-pkgname=("python-dill" "python2-dill")
-pkgbase=python-dill
-pkgver=0.3.0
-pkgrel=1
+pkgname=python-dill
+pkgver=0.3.3
+pkgrel=2
pkgdesc='Serialize all of python (almost)'
arch=('any')
url='http://pypi.python.org/pypi/dill/'
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('python-objgraph')
license=('BSD')
-source=("https://github.com/uqfoundation/dill/archive/dill-$pkgver.tar.gz" "python2-dill.install")
-md5sums=('bf5c2ca7c8441fc6c8908fd316b7de2b'
- '2ac075f39bab33c203e7b25adb3e07b3')
+source=("https://github.com/uqfoundation/dill/archive/dill-$pkgver.tar.gz")
+md5sums=('80e782f27a5198238c6b43d75acea68d')
build() {
cd "$srcdir/dill-dill-$pkgver"
python setup.py build
}
-package_python-dill() {
- depends=('python')
- optdepends=('python-pyreadline' 'python-objgraph')
+package() {
cd "$srcdir/dill-dill-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-package_python2-dill() {
- depends=('python2')
- optdepends=('python2-pyreadline' 'python2-objgraph')
- install=python2-dill.install
- cd "$srcdir/dill-dill-$pkgver"
- find . -name "*.py" -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} \;
- python2 setup.py install --root="$pkgdir/" --optimize=1
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- mv "$pkgdir/usr/bin/get_objgraph" "$pkgdir/usr/bin/get_objgraph2"
- mv "$pkgdir/usr/bin/undill" "$pkgdir/usr/bin/undill2"
-}
diff --git a/python2-dill.install b/python2-dill.install
deleted file mode 100644
index f576fb01a432..000000000000
--- a/python2-dill.install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_install(){
- cat << \here
-Accompanying programs dill_unpickle.py and get_objgraph.py are available as dill_unpickle2.py and get_objgraph2.py.
-Attention: dill_unpickle.py was known as unpickle.py before.
-here
-}
-
-post_upgrade(){
- post_install
-}