summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b49568be1ac7..ec277a5ee64b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jun 25 16:24:19 UTC 2017
+# Mon Jul 3 07:26:23 UTC 2017
pkgbase = python-dill
pkgdesc = Serialize all of python (almost)
pkgver = 0.2.6
@@ -7,6 +7,8 @@ pkgbase = python-dill
url = http://pypi.python.org/pypi/dill/
arch = any
license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
source = https://github.com/uqfoundation/dill/releases/download/0.2.6/dill-0.2.6.tgz
source = python2-dill.install
md5sums = eff3385ff87c3de142ce502b38fb928a
diff --git a/PKGBUILD b/PKGBUILD
index 4f4e54587a7b..4c2e5cba0475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ pkgrel=4
pkgdesc='Serialize all of python (almost)'
arch=('any')
url='http://pypi.python.org/pypi/dill/'
+makedepends=('python-setuptools' 'python2-setuptools')
license=('BSD')
source=("https://github.com/uqfoundation/dill/releases/download/$pkgver/dill-$pkgver.tgz" "python2-dill.install")
md5sums=('eff3385ff87c3de142ce502b38fb928a'
@@ -20,7 +21,6 @@ build() {
package_python-dill() {
depends=('python')
- makedepends=('python-setuptools')
cd "$srcdir/dill-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -28,7 +28,6 @@ package_python-dill() {
package_python2-dill() {
depends=('python2')
- makedepends=('python2-setuptools')
install=python2-dill.install
cd "$srcdir/dill-$pkgver"
find . -name "*.py" -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} \;