summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a5ae3261565..cd54505a2638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-distributed
pkgdesc = Python library for distributed computing
- pkgver = 2.13.0
+ pkgver = 2.14.0
pkgrel = 1
url = https://distributed.dask.org/
arch = any
@@ -18,6 +18,7 @@ pkgbase = python-distributed
depends = python-tornado
depends = python-zict
depends = python-yaml
+ optdepends = python-cytoolz: Cython version of python-toolz for improved performance
optdepends = python-joblib: Joblib integration
optdepends = python-pandas: Pandas integration
optdepends = python-numpy: NumPy integration
@@ -33,8 +34,8 @@ pkgbase = python-distributed
optdepends = python-asyncssh: Computing cluster using SSH communication
optdepends = python-pytorch: Support for tensors and dynamic neural networks
optdepends = python-ipywidgets: Extra widgets in diagnostic pages
- source = https://files.pythonhosted.org/packages/source/d/distributed/distributed-2.13.0.tar.gz
- sha256sums = 249156c458fa1c0d7c9fb0781bb68d710cc6169e1aebbf87667b708c5cfc609f
+ source = https://files.pythonhosted.org/packages/source/d/distributed/distributed-2.14.0.tar.gz
+ sha256sums = d9d49536fefc4238417de89bc6ddcc1cfa64da90d52b74128a16d9d28a823089
pkgname = python-distributed
diff --git a/PKGBUILD b/PKGBUILD
index 2107a0ffe9d1..05123ab7b9ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-distributed
_pkgname=distributed
-pkgver=2.13.0
+pkgver=2.14.0
pkgrel=1
pkgdesc="Python library for distributed computing"
arch=('any')
@@ -13,6 +13,8 @@ depends=(
'python-tornado' 'python-zict' 'python-yaml'
)
optdepends=(
+ 'python-cytoolz: Cython version of python-toolz for improved performance'
+
# Packages suggested in dev-requirements.txt
'python-joblib: Joblib integration'
'python-pandas: Pandas integration'
@@ -39,7 +41,7 @@ source=(
"https://files.pythonhosted.org/packages/source/d/distributed/distributed-$pkgver.tar.gz"
)
sha256sums=(
- '249156c458fa1c0d7c9fb0781bb68d710cc6169e1aebbf87667b708c5cfc609f'
+ 'd9d49536fefc4238417de89bc6ddcc1cfa64da90d52b74128a16d9d28a823089'
)
build() {