summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97e564ad09ed..ac49c99997d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,16 @@
pkgbase = python-django-dynamic-preferences
pkgdesc = Dynamic global and instance settings for your django project
- pkgver = 1.10.1
+ pkgver = 1.11.0
pkgrel = 1
url = https://github.com/EliotBerriot/django-dynamic-preferences
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- options = !emptydirs
- source = python-django-dynamic-preferences-1.10.1.tar.gz::https://github.com/EliotBerriot/django-dynamic-preferences/archive/1.10.1.tar.gz
- sha256sums = f7ded092990ab0dafd50db696475a34a5ae52873d48d08915635862c7a532707
-
-pkgname = python-django-dynamic-preferences
depends = python-wheel
depends = python-django
depends = python-persisting-theory
+ options = !emptydirs
+ source = python-django-dynamic-preferences-1.11.0.tar.gz::https://github.com/EliotBerriot/django-dynamic-preferences/archive/1.11.0.tar.gz
+ sha256sums = d1691cc70fe668db4a6c1cfdb90db126011ba0448f2cd85c4d2a993310236c37
-pkgname = python2-django-dynamic-preferences
- depends = python2-wheel
- depends = python2-django
- depends = python2-persisting-theory
-
+pkgname = python-django-dynamic-preferences
diff --git a/PKGBUILD b/PKGBUILD
index 2dc09cf6f5f8..5a3888587c61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: getzze <getzze at gmail dot com>
-pkgname=('python-django-dynamic-preferences' 'python2-django-dynamic-preferences')
-pkgver=1.10.1
+pkgname='python-django-dynamic-preferences'
+pkgver=1.11.0
pkgrel=1
pkgdesc="Dynamic global and instance settings for your django project"
arch=(any)
@@ -9,19 +9,12 @@ url="https://github.com/EliotBerriot/django-dynamic-preferences"
license=('BSD')
options=(!emptydirs)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('f7ded092990ab0dafd50db696475a34a5ae52873d48d08915635862c7a532707')
-makedepends=('python-setuptools' 'python2-setuptools')
+sha256sums=('d1691cc70fe668db4a6c1cfdb90db126011ba0448f2cd85c4d2a993310236c37')
+makedepends=('python-setuptools')
+depends=('python-wheel' 'python-django' 'python-persisting-theory')
-package_python-django-dynamic-preferences() {
- depends=('python-wheel' 'python-django' 'python-persisting-theory')
+package() {
cd "$srcdir/django-dynamic-preferences-$pkgver"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
python setup.py install --root="$pkgdir/" --optimize=1
}
-
-package_python2-django-dynamic-preferences() {
- depends=('python2-wheel' 'python2-django' 'python2-persisting-theory')
- cd "$srcdir/django-dynamic-preferences-$pkgver"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python2 setup.py install --root="$pkgdir/" --optimize=1
-}