summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3dfe5bde123..1c08a69505f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-django-etesync-journal
pkgdesc = The server side implementation of the EteSync protocol.
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://pypi.org/project/django-etesync-journal/
arch = any
license = AGPL3
makedepends = python-setuptools
+ depends = python-django
+ depends = python-django-rest-framework
+ depends = python-drf-nested-routers
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/d/django-etesync-journal/django-etesync-journal-1.0.2.tar.gz
sha256sums = 716df1fc8670c79750e8a1e736b69ddbdbd238237565874ea9648387cc50626e
diff --git a/PKGBUILD b/PKGBUILD
index 271cec687e3d..cba730bbb652 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,18 @@
pkgname=('python-django-etesync-journal')
_name=${pkgname#python-}
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="The server side implementation of the EteSync protocol."
arch=(any)
url="https://pypi.org/project/django-etesync-journal/"
license=('AGPL3')
+depends=('python-django'
+ 'python-django-rest-framework'
+ 'python-drf-nested-routers')
+makedepends=('python-setuptools')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('716df1fc8670c79750e8a1e736b69ddbdbd238237565874ea9648387cc50626e')
-makedepends=('python-setuptools')
build() {
cd ${srcdir}/$_name-${pkgver}