summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f02e1983402
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-django-rest-auth
+ pkgdesc = Django-rest-auth provides a set of REST API endpoints for Authentication and Registration
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/Tivix/django-rest-auth/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-django
+ depends = python-django-rest-framework
+ source = https://github.com/Tivix/django-rest-auth/archive/v0.9.0.tar.gz
+ md5sums = SKIP
+
+pkgname = python-django-rest-auth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2f5371e5411
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Razer <razer@neuf.fr>
+
+pkgname=python-django-rest-auth
+_pypi_pkgname=django-rest-auth
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Django-rest-auth provides a set of REST API endpoints for Authentication and Registration"
+arch=(any)
+url="https://github.com/Tivix/django-rest-auth/"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python' 'python-django' 'python-django-rest-framework')
+source=("https://github.com/Tivix/django-rest-auth/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+
+