summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD67
3 files changed, 31 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3665d86842ee..b450078d5620 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,13 @@
pkgbase = python-django-reversion
- pkgver = 1.8.2
- pkgrel = 2
- url = http://github.com/etianen/django-reversion
- arch = i686
- arch = x86_64
- license = BSD
- makedepends = python2
- makedepends = python
- source = https://pypi.python.org/packages/source/d/django-reversion/django-reversion-1.8.2.tar.gz
- md5sums = b00c492284c776a69ff6cc43247be682
+ pkgdesc = An extension to the Django web framework that provides version control for model instances
+ pkgver = 5.0.12
+ pkgrel = 1
+ url = https://github.com/etianen/django-reversion
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python-django
+ source = https://github.com/etianen/django-reversion/archive/v5.0.12.tar.gz
+ sha512sums = 5c45f18b35135d36d97a09b5e983994ac5193b631b0d471d530fe24db283b2958cd6fa1f698d0d9c520c93a3a3d4f5f607f8e127eeeaa335405ac7e342193135
pkgname = python-django-reversion
- pkgdesc = An python3 extension to the Django web framework that provides comprehensive version control facilities
- depends = python
-
-pkgname = python2-django-reversion
- pkgdesc = An python2 extension to the Django web framework that provides comprehensive version control facilities
- depends = python2
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 742c6abc623b..bed1b5b4b42d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,25 @@
-# Maintainer: mawcomw <mawcomw@gmail.com>
-
-pkgbase=python-django-reversion
-pkgname=('python-django-reversion' 'python2-django-reversion')
-pkgver=1.8.2
-pkgrel=2
-arch=('i686' 'x86_64')
-url="http://github.com/etianen/django-reversion"
-license=('BSD')
-makedepends=('python2' 'python')
-source=("https://pypi.python.org/packages/source/d/django-reversion/django-reversion-$pkgver.tar.gz")
-md5sums=('b00c492284c776a69ff6cc43247be682')
-
-prepare() {
- cp -r django-reversion-${pkgver} python2-django-reversion-${pkgver}
-}
+# Contributor: mawcomw <mawcomw@gmail.com>
+_base=django-reversion
+pkgname=python-${_base}
+pkgver=5.0.12
+pkgrel=1
+arch=(any)
+url="https://github.com/etianen/${_base}"
+pkgdesc="An extension to the Django web framework that provides version control for model instances"
+license=('custom')
+depends=(python-django)
+makedepends=(python-setuptools)
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('5c45f18b35135d36d97a09b5e983994ac5193b631b0d471d530fe24db283b2958cd6fa1f698d0d9c520c93a3a3d4f5f607f8e127eeeaa335405ac7e342193135')
build() {
- cd $srcdir/django-reversion-${pkgver}
- python setup.py build
-
- cd $srcdir/python2-django-reversion-${pkgver}
- python2 setup.py build
+ cd "${_base}-${pkgver}"
+ python setup.py build
}
-#check(){
-# cd $srcdir/django-reversion-${pkgver}
-# python setup.py test
-#
-# cd $srcdir/python2-django-reversion-${pkgver}
-# python2 setup.py test
-#}
-
-package_python-django-reversion() {
- depends=('python' )
- pkgdesc="An python3 extension to the Django web framework that provides comprehensive version control facilities"
-
- cd $srcdir/django-reversion-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
-
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
+package() {
+ cd "${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-package_python2-django-reversion() {
- depends=('python2' )
- pkgdesc="An python2 extension to the Django web framework that provides comprehensive version control facilities"
-
- cd python2-django-reversion-${pkgver}
- python2 setup.py install --root="${pkgdir}" --optimize=1
-
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE
-} \ No newline at end of file