summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 21 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cf357ddc9d9..f334e1d29976 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,16 @@
pkgbase = python-django-simple-captcha
pkgdesc = Django application to add captcha images to any Django form
- pkgver = 0.5.10
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/mbi/django-simple-captcha
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://github.com/mbi/django-simple-captcha/archive/v0.5.10.tar.gz
- sha256sums = 31dbdaa819c8c40c20519c0d48e0b8059ca2ffc8bdfa671271f2f133c47be4cd
-
-pkgname = python-django-simple-captcha
depends = python-django
depends = python-six
depends = python-pillow
depends = python-django-ranged-response
+ source = python-django-simple-captcha-0.6.0.tar.gz::https://github.com/mbi/django-simple-captcha/archive/v0.6.0.tar.gz
+ sha256sums = 0b798d7572df98330c9975cd343a229b787d30bf9fdb8b852b307b5073af0ed0
-pkgname = python2-django-simple-captcha
- depends = python2-django
- depends = python2-six
- depends = python2-pillow
- depends = python2-django-ranged-response
-
+pkgname = python-django-simple-captcha
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7b4db42c16c2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.gz
+*.xz
+*.zip
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
index 7fa81966c2b4..1d68726d9721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,24 @@
# Maintainer: Joffrey <j-off@live.fr>
-pkgbase='python-django-simple-captcha'
-pkgname=('python-django-simple-captcha' 'python2-django-simple-captcha')
-pkgver='0.5.10'
+pkgname='python-django-simple-captcha'
+pkgver=0.6.0
pkgrel=1
pkgdesc='Django application to add captcha images to any Django form'
arch=('any')
url='https://github.com/mbi/django-simple-captcha'
license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://github.com/mbi/django-simple-captcha/archive/v$pkgver.tar.gz")
-sha256sums=('31dbdaa819c8c40c20519c0d48e0b8059ca2ffc8bdfa671271f2f133c47be4cd')
+depends=(
+ 'python-django'
+ 'python-six'
+ 'python-pillow'
+ 'python-django-ranged-response'
+)
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('0b798d7572df98330c9975cd343a229b787d30bf9fdb8b852b307b5073af0ed0')
-package_python-django-simple-captcha() {
- depends=(
- 'python-django'
- 'python-six'
- 'python-pillow'
- 'python-django-ranged-response'
- )
+package() {
cd "$srcdir/django-simple-captcha-$pkgver"
install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python './setup.py' install --root="$pkgdir" --optimize=1
}
-
-package_python2-django-simple-captcha() {
- depends=(
- 'python2-django'
- 'python2-six'
- 'python2-pillow'
- 'python2-django-ranged-response'
- )
- cd "$srcdir/django-simple-captcha-$pkgver"
- install -Dm644 './LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python2 './setup.py' install --root="$pkgdir" --optimize=1
-}