summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43043aa48f21..d5d385b1191f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-dodgy
pkgdesc = Looks at Python code to search for things which look dodgy such as passwords or diffs
- pkgver = 0.1.9
+ pkgver = 0.2.1
pkgrel = 1
url = https://github.com/landscapeio/dodgy
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = git
depends = python
- source = https://github.com/landscapeio/dodgy/archive/0.1.9.tar.gz
- md5sums = fd268f48162cc6a5dc62f784b7d61e85
+ source = git+https://github.com/landscapeio/dodgy#tag=0.2.1
+ sha256sums = SKIP
pkgname = python-dodgy
diff --git a/PKGBUILD b/PKGBUILD
index 297171d2e167..4d5b85c8e531 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-_pkgname=dodgy
pkgname=python-dodgy
-pkgver=0.1.9
+pkgver=0.2.1
pkgrel=1
pkgdesc="Looks at Python code to search for things which look dodgy such as passwords or diffs"
arch=('any')
url="https://github.com/landscapeio/dodgy"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
-source=(https://github.com/landscapeio/dodgy/archive/${pkgver}.tar.gz)
-md5sums=('fd268f48162cc6a5dc62f784b7d61e85')
+makedepends=('python-setuptools' 'git')
+source=(git+https://github.com/landscapeio/dodgy#tag=${pkgver})
+sha256sums=('SKIP')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "dodgy"
python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "dodgy"
- python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
- install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+ python setup.py install --prefix="/usr" --root="${pkgdir}" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
}
-# vim:set ts=2 sw=2 et: