summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD17
3 files changed, 13 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 156c2300246e..ee2f5080e508 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-doit
pkgdesc = doit automation tool
pkgver = 0.29.0
- pkgrel = 1
+ pkgrel = 2
url = http://pydoit.org/
arch = any
license = MIT
@@ -11,23 +11,25 @@ pkgbase = python-doit
makedepends = python2-setuptools
makedepends = python-pyinotify
makedepends = python-six
+ makedepends = python-cloudpickle
makedepends = python2-pyinotify
makedepends = python2-six
+ makedepends = python2-cloudpickle
options = !emptydirs
source = https://pypi.python.org/packages/source/d/doit/doit-0.29.0.tar.gz
- source = LICENSE
md5sums = 9968e1a669bad0a999212ab9f5c591a3
- md5sums = 7d6fd7c8e022bae9010af272c31eb45f
pkgname = python-doit
depends = python
depends = python-pyinotify
depends = python-six
depends = python-setuptools
+ depends = python-cloudpickle
pkgname = python2-doit
depends = python2
depends = python2-pyinotify
depends = python2-six
depends = python2-setuptools
+ depends = python2-cloudpickle
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 9340ee9a6b68..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,23 +0,0 @@
-
-
-The MIT License
-
-Copyright (c) 2008-2011 Eduardo Naufel Schettino
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index f6f8c4f78c74..b6aed954ca95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,17 @@ pkgbase=python-doit
pkgname=('python-doit' 'python2-doit')
_pyname=doit
pkgver=0.29.0
-pkgrel=1
+pkgrel=2
pkgdesc='doit automation tool'
arch=('any')
url='http://pydoit.org/'
license=('MIT')
makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools'
- 'python-pyinotify' 'python-six' 'python2-pyinotify' 'python2-six')
+ 'python-pyinotify' 'python-six' 'python-cloudpickle'
+ 'python2-pyinotify' 'python2-six' 'python2-cloudpickle')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- "LICENSE")
-md5sums=('9968e1a669bad0a999212ab9f5c591a3'
- '7d6fd7c8e022bae9010af272c31eb45f')
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('9968e1a669bad0a999212ab9f5c591a3')
prepare() {
cd "${srcdir}/${_pyname}-${pkgver}"
@@ -22,17 +21,17 @@ prepare() {
}
package_python-doit() {
- depends=('python' 'python-pyinotify' 'python-six' 'python-setuptools')
+ depends=('python' 'python-pyinotify' 'python-six' 'python-setuptools' 'python-cloudpickle')
cd "${srcdir}/${_pyname}-${pkgver}"
python3 setup.py install --root="${pkgdir}/" --optimize=1
- install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
ln -s ${_pyname} "${pkgdir}/usr/bin/${_pyname}3"
install -D -m755 'zsh_completion_doit' "${pkgdir}/usr/share/zsh/site-functions/_${_pyname}"
install -D -m755 'bash_completion_doit' "${pkgdir}/usr/share/bash-completion/completions/${_pyname}"
}
package_python2-doit() {
- depends=('python2' 'python2-pyinotify' 'python2-six' 'python2-setuptools')
+ depends=('python2' 'python2-pyinotify' 'python2-six' 'python2-setuptools' 'python2-cloudpickle')
cd "${srcdir}/${_pyname}-${pkgver}-py2"
python2 setup.py install --root="${pkgdir}/" --optimize=1
mv "${pkgdir}/usr/bin/${_pyname}" "${pkgdir}/usr/bin/${_pyname}2"