summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a65c1f3adf01..ac1477729bd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ecos
pkgdesc = Python interface for ECOS.
- pkgver = 2.0.7
+ pkgver = 2.0.11
pkgrel = 1
url = https://github.com/embotech/ecos-python
arch = x86_64
@@ -11,10 +11,9 @@ pkgbase = python-ecos
depends = python-scipy
depends = ecos
depends = suitesparse
- source = https://github.com/embotech/ecos-python/archive/2.0.7.tar.gz
+ source = python-ecos-2.0.11.tar.gz::https://github.com/embotech/ecos-python/archive/v2.0.11.tar.gz
source = use_external_ecos.patch
- sha256sums = 5cec19d5647b2bf8f07c7c06c7005d2113c44a911dd7832a4955b228af19982c
+ sha256sums = 01ebd3fc8a54822e035c5d69f750fc577001754a057a6a023b68e736c43a7823
sha256sums = c929cbe71cf8a109a66cbc681c6c501c42517b44e63f88440c36e5c7ca9e3be9
pkgname = python-ecos
-
diff --git a/PKGBUILD b/PKGBUILD
index 4b779f203141..baf4dd5516c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-ecos'
_module='ecos-python'
-pkgver='2.0.7'
+pkgver='2.0.11'
pkgrel=1
pkgdesc="Python interface for ECOS."
url="https://github.com/embotech/ecos-python"
@@ -13,29 +13,29 @@ makedepends=('python-setuptools')
checkdepends=('python-nose')
license=('GPL3')
arch=('x86_64')
-source=("https://github.com/embotech/ecos-python/archive/${pkgver}.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/embotech/ecos-python/archive/v${pkgver}.tar.gz"
"use_external_ecos.patch")
-sha256sums=('5cec19d5647b2bf8f07c7c06c7005d2113c44a911dd7832a4955b228af19982c'
+sha256sums=('01ebd3fc8a54822e035c5d69f750fc577001754a057a6a023b68e736c43a7823'
'c929cbe71cf8a109a66cbc681c6c501c42517b44e63f88440c36e5c7ca9e3be9')
prepare() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
patch -p1 < ../use_external_ecos.patch
}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
make version
python setup.py build
}
check() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py build_ext --inplace
nosetests
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}