summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
-rw-r--r--use_external_ecos.patch15
3 files changed, 29 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb982e6a1c4e..7d8219748a97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python-ecos
pkgdesc = Python interface for ECOS.
- pkgver = 2.0.4
+ pkgver = 2.0.7
pkgrel = 1
url = https://github.com/embotech/ecos-python
- arch = i686
arch = x86_64
license = GPL3
makedepends = python-setuptools
@@ -12,10 +11,11 @@ pkgbase = python-ecos
depends = python-scipy
depends = ecos
depends = suitesparse
- source = https://github.com/embotech/ecos-python/archive/v2.0.4.tar.gz
+ optdepends = python-nose
+ source = https://github.com/embotech/ecos-python/archive/2.0.7rc2.tar.gz
source = use_external_ecos.patch
- sha256sums = d16907b0e9f41bbe7f43c37562e0d361db1f4d2e5fc7e91125899b4fdd062790
- sha256sums = 49303c5fe700ccdc06fabdab87e5a0518b495fe32a99b2062f301e15dc4a0c72
+ sha256sums = aba90a898da8a3f679e6169ee02c8d604960e721a6ff591671d2695efc5bab20
+ sha256sums = c929cbe71cf8a109a66cbc681c6c501c42517b44e63f88440c36e5c7ca9e3be9
pkgname = python-ecos
diff --git a/PKGBUILD b/PKGBUILD
index 3ad1c88c5800..1eb92eb71764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgbase=('python-ecos')
pkgname=('python-ecos')
_module='ecos-python'
-pkgver='2.0.4'
+pkgver='2.0.7'
+_pkgver="${pkgver}rc2"
pkgrel=1
pkgdesc="Python interface for ECOS."
url="https://github.com/embotech/ecos-python"
@@ -12,24 +12,31 @@ depends=('python'
'ecos'
'suitesparse')
makedepends=('python-setuptools')
+optdepends=('python-nose')
license=('GPL3')
-arch=('i686' 'x86_64')
-source=("https://github.com/embotech/ecos-python/archive/v${pkgver}.tar.gz"
+arch=('x86_64')
+source=("https://github.com/embotech/ecos-python/archive/${_pkgver}.tar.gz"
"use_external_ecos.patch")
-sha256sums=('d16907b0e9f41bbe7f43c37562e0d361db1f4d2e5fc7e91125899b4fdd062790'
- '49303c5fe700ccdc06fabdab87e5a0518b495fe32a99b2062f301e15dc4a0c72')
+sha256sums=('aba90a898da8a3f679e6169ee02c8d604960e721a6ff591671d2695efc5bab20'
+ 'c929cbe71cf8a109a66cbc681c6c501c42517b44e63f88440c36e5c7ca9e3be9')
prepare() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${_pkgver}"
patch -p1 < ../use_external_ecos.patch
}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${_pkgver}"
python setup.py build
}
+check() {
+ cd "${srcdir}/${_module}-${_pkgver}"
+ python setup.py build_ext --inplace
+ nosetests
+}
+
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${_module}-${_pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}
diff --git a/use_external_ecos.patch b/use_external_ecos.patch
index 34e2e916338c..6063a538d819 100644
--- a/use_external_ecos.patch
+++ b/use_external_ecos.patch
@@ -1,8 +1,9 @@
---- ecos-python-2.0.4-orig/setup.py 2015-09-10 11:33:19.000000000 -0400
-+++ ecos-python-2.0.4/setup.py 2017-01-20 10:35:13.330569455 -0500
+diff -urN ecos-python-2.0.7rc2-orig/setup.py ecos-python-2.0.7rc2/setup.py
+--- ecos-python-2.0.7rc2-orig/setup.py 2018-05-23 22:16:42.967677526 -0400
++++ ecos-python-2.0.7rc2/setup.py 2018-05-23 22:17:41.981221901 -0400
@@ -9,7 +9,7 @@
+ from glob import glob
from platform import system
- import numpy
-lib = []
+lib = ['ecos']
@@ -13,7 +14,7 @@
('DLONG', None),
('LDL_LONG', None),
('CTRLC', 1)],
-- include_dirs = ['ecos/include', numpy.get_include(),
+- include_dirs = ['ecos/include',
- 'ecos/external/amd/include',
- 'ecos/external/ldl/include',
- 'ecos/external/SuiteSparse_config'],
@@ -32,8 +33,8 @@
- 'ecos/src/wright_omega.c'
- ] + glob('ecos/external/amd/src/*.c')
- + glob('ecos/ecos_bb/*.c')) # glob bb source files
-+ include_dirs = ['/usr/include/ecos/', numpy.get_include()],
++ include_dirs = ['/usr/include/ecos'],
+ sources = ['src/ecosmodule.c'])
- setup(
- name = 'ecos',
+ def set_builtin(name, value):
+ if isinstance(__builtins__, dict):