summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..024e606d9afd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-einsteinpy_geodesics-doc
+ pkgdesc = Documentation for EinsteinPy Geodesics
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://docs.geodesics.einsteinpy.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python-einsteinpy_geodesics=0.1.0
+ makedepends = python-sphinx
+ source = https://github.com/einsteinpy/einsteinpy-geodesics/archive/v0.1.0.tar.gz
+ md5sums = 5c43ab1cd6ebeef77cf156bd098abe03
+
+pkgname = python-einsteinpy_geodesics-doc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e896dcd6056d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38e71b8bec53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=einsteinpy-geodesics
+pkgname=python-${_pyname/-/_}-doc
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Documentation for EinsteinPy Geodesics"
+arch=('i686' 'x86_64')
+url="https://docs.geodesics.einsteinpy.org"
+license=('MIT')
+makedepends=("python-${_pyname/-/_}=${pkgver}" 'python-sphinx')
+#'python-nbsphinx' 'pandoc' 'graphviz')
+source=("https://github.com/einsteinpy/einsteinpy-geodesics/archive/v${pkgver}.tar.gz")
+md5sums=('5c43ab1cd6ebeef77cf156bd098abe03')
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../COPYING
+}