summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d076128f4ae..ce1fbdb412c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-epics
pkgdesc = Python interface to Epics Channel Access
- pkgver = 3.4.1
+ pkgver = 3.5.5
pkgrel = 1
url = http://pyepics.github.io/pyepics/
arch = any
- license = custom
+ license = custom:Epics Open License
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = python-numpy
depends = epics-base
- source = https://github.com/pyepics/pyepics/archive/3.4.1.tar.gz
- sha256sums = e3b852a98e483b6a6b53af94ab4aa1d3d51ac49434bfae32fcdacae31577e8d0
+ source = https://github.com/pyepics/pyepics/archive/refs/tags/3.5.5.tar.gz
+ sha512sums = SKIP
pkgname = python-epics
-
diff --git a/PKGBUILD b/PKGBUILD
index 677754484ee8..908e901dfb14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
-# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+# Contributor: Grey Christoforo <first name at last name dot net>
+# Contributor: Rafael Silva <perigoso at riseup dot net>
-pkgname=python-epics
-_pkgname=pyepics
-pkgver=3.4.1
+pkgname='python-epics'
+_name='pyepics'
+pkgver=3.5.5
pkgrel=1
-pkgdesc="Python interface to Epics Channel Access "
+pkgdesc="Python interface to Epics Channel Access"
arch=('any')
-url=http://pyepics.github.io/pyepics/
-license=('custom')
+url="http://pyepics.github.io/pyepics/"
+license=('custom:Epics Open License')
depends=('python' 'python-numpy' 'epics-base')
-makedepends=('python-setuptools')
-source=("https://github.com/pyepics/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('e3b852a98e483b6a6b53af94ab4aa1d3d51ac49434bfae32fcdacae31577e8d0')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
+source=("https://github.com/pyepics/$_name/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=('SKIP')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py build
-}
+ cd "$_name-$pkgver"
+ # Workaround for python-setuptools-scm
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ python -m build --wheel --no-isolation
+}
package(){
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
-}
+ cd "$_name-$pkgver"
-# vim:ts=2:sw=2:et:
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}