summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9b63b7c9a6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-eth-hash
+ pkgdesc = The Ethereum hashing function, keccak256, sometimes (erroneously) called sha256 or sha3.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/ethereum/eth-hash
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pysha3
+ depends = python-pycryptodome
+ source = https://github.com/ethereum/eth-hash/archive/v0.2.0.tar.gz
+ sha256sums = 4f275118ae0f26c9f3f7c9fc4feee308a9d32d04fd23b6c8ba25329d0e3da219
+
+pkgname = python-eth-hash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da2eff312e11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: algebro <algebro at tuta dot io>
+
+_pkgname=eth-hash
+pkgname=python-$_pkgname
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="The Ethereum hashing function, keccak256, sometimes (erroneously) called sha256 or sha3."
+arch=('x86_64')
+url="https://github.com/ethereum/eth-hash"
+license=('MIT')
+depends=('python' 'python-pysha3' 'python-pycryptodome')
+makedepends=('python-setuptools')
+source=("https://github.com/ethereum/eth-hash/archive/v${pkgver}.tar.gz")
+sha256sums=('4f275118ae0f26c9f3f7c9fc4feee308a9d32d04fd23b6c8ba25329d0e3da219')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root=$pkgdir --optimize=1 --skip-build
+}