summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
-rw-r--r--python-fasttext-cstdint.patch11
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3ed40cdd710..4211144280eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-fasttext
pkgdesc = Library for fast text representation and classification – Python bindings
pkgver = 0.9.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/facebookresearch/fastText
arch = x86_64
license = BSD
@@ -14,6 +14,8 @@ pkgbase = python-fasttext
provides = python-fasttext
conflicts = python-fasttext
source = python-fasttext-0.9.2.tar.gz::https://github.com/facebookresearch/fastText/archive/v0.9.2.tar.gz
- sha256sums = 7ea4edcdb64bfc6faaaec193ef181bdc108ee62bb6a04e48b2e80b639a99e27e
+ source = python-fasttext-cstdint.patch
+ b2sums = ea3af92ce18d04241128cfb28773f0785a006e79c861d718c2c6ad788d776ad60b0543a42eb8be5a865cbc12283355521431fe2fba48544399e4a2b1520ff3f1
+ b2sums = 5d7c95b54ceb1998b4fd62ce11b6ac94f5c5f95f46488b8da79b04e2b7275bde6af105b120ef61ce81d16418a822b105cc84007f2398e6eb1982b916ff689281
pkgname = python-fasttext
diff --git a/PKGBUILD b/PKGBUILD
index 5d39a128e09a..b650027b92a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ provides=("python-fasttext")
conflicts=("python-fasttext")
pkgver=0.9.2
-pkgrel=3
+pkgrel=4
arch=("x86_64")
license=("BSD")
@@ -16,10 +16,22 @@ license=("BSD")
makedepends=("python-setuptools")
depends=("pybind11" "python-future" "python-numpy" "python-scipy" "python-pytorch")
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz")
-sha256sums=("7ea4edcdb64bfc6faaaec193ef181bdc108ee62bb6a04e48b2e80b639a99e27e")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz"
+ "${pkgname}-cstdint.patch"
+)
+b2sums=(
+ "ea3af92ce18d04241128cfb28773f0785a006e79c861d718c2c6ad788d776ad60b0543a42eb8be5a865cbc12283355521431fe2fba48544399e4a2b1520ff3f1"
+ "5d7c95b54ceb1998b4fd62ce11b6ac94f5c5f95f46488b8da79b04e2b7275bde6af105b120ef61ce81d16418a822b105cc84007f2398e6eb1982b916ff689281"
+)
+
+prepare() {
+ cd "${srcdir}/fastText-${pkgver}"
+ patch --forward --strip=1 --input "${srcdir}/${pkgname}-cstdint.patch"
+}
build() {
+ export CXXFLAGS="${CXXFLAGS} -std=c++0x"
cd "${srcdir}/fastText-${pkgver}"
python setup.py build
}
diff --git a/python-fasttext-cstdint.patch b/python-fasttext-cstdint.patch
new file mode 100644
index 000000000000..c6462e0b6032
--- /dev/null
+++ b/python-fasttext-cstdint.patch
@@ -0,0 +1,11 @@
+diff --unified --recursive --text a/src/args.cc b/src/args.cc
+--- a/src/args.cc 2020-04-28 12:40:33.000000000 +0300
++++ b/src/args.cc 2023-05-16 11:48:14.001866135 +0300
+@@ -14,6 +14,7 @@
+ #include <stdexcept>
+ #include <string>
+ #include <unordered_map>
++#include <cstdint>
+
+ namespace fasttext {
+