summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD30
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1101c72a14c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-fasttext-git
+ pkgdesc = Library for fast text representation and classification – Python bindings
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/facebookresearch/fastText
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = pybind11
+ depends = python-future
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-pytorch
+ provides = python-fasttext
+ conflicts = python-fasttext
+ source = https://github.com/facebookresearch/fastText/archive/v0.2.0.tar.gz
+ sha256sums = 71d24ffec9fcc4364554ecac2b3308d834178c903d16d090aa6be9ea6b8e480c
+
+pkgname = python-fasttext-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35daaa7ef0c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+
+pkgname='python-fasttext-git'
+pkgdesc="Library for fast text representation and classification – Python bindings"
+url="https://github.com/facebookresearch/fastText"
+
+provides=('python-fasttext')
+conflicts=('python-fasttext')
+
+pkgver=0.2.0
+pkgrel=1
+
+arch=('any')
+license=('BSD')
+
+makedepends=('python-setuptools' 'python2-setuptools')
+depends=('pybind11' 'python-future' 'python-numpy' 'python-scipy' 'python-pytorch')
+
+source=("https://github.com/facebookresearch/fastText/archive/v${pkgver}.tar.gz")
+sha256sums=('71d24ffec9fcc4364554ecac2b3308d834178c903d16d090aa6be9ea6b8e480c')
+
+build() {
+ cd "${srcdir}/fastText-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/fastText-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1
+}