summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c4d22130dbe..7dc642054c57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-feather
pkgdesc = Fast, interoperable binary data frame storage for Python, R
- pkgver = 0.4.0
+ pkgver = 0.4.1
pkgrel = 1
url = https://github.com/wesm/feather
arch = any
license = Apache
makedepends = python-setuptools
- depends = python
depends = python-pandas>=0.17.1
depends = python-pyarrow>=0.4.0
- source = https://github.com/wesm/feather/archive/v0.4.0.tar.gz
- sha256sums = 62be8619cd56e5c4ba5c5095e01732ccb125ba56c83a4cba0f6e6293a5e4b348
+ source = python-feather-0.4.1.tar.gz::https://github.com/wesm/feather/archive/v0.4.1.tar.gz
+ sha256sums = 5e230cf7d270c73ac032498ae7f77c13c169ab89b845c4432e3a5f061b0287b3
pkgname = python-feather
diff --git a/PKGBUILD b/PKGBUILD
index 656a34fea76b..dc7cccd7e93c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-feather')
+pkgname='python-feather'
_module='feather'
-pkgver='0.4.0'
+pkgver=0.4.1
pkgrel=1
pkgdesc="Fast, interoperable binary data frame storage for Python, R"
url="https://github.com/wesm/feather"
-depends=('python'
- 'python-pandas>=0.17.1'
+depends=('python-pandas>=0.17.1'
'python-pyarrow>=0.4.0')
makedepends=('python-setuptools')
license=('Apache')
arch=('any')
-source=("https://github.com/wesm/feather/archive/v$pkgver.tar.gz")
-sha256sums=('62be8619cd56e5c4ba5c5095e01732ccb125ba56c83a4cba0f6e6293a5e4b348')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wesm/feather/archive/v$pkgver.tar.gz")
+sha256sums=('5e230cf7d270c73ac032498ae7f77c13c169ab89b845c4432e3a5f061b0287b3')
build() {
- cd "${srcdir}/${_module}-${pkgver}/python"
+ cd "${_module}-${pkgver}/python"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}/python"
+ cd "${_module}-${pkgver}/python"
python setup.py install --root="${pkgdir}" --optimize=1
}