summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD25
3 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0538d8347298..73c0a9de90a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-fenicsprecice
pkgdesc = FEniCS-preCICE adapter is a preCICE adapter for the open source computing platform FEniCS
- pkgver = 1.3.0
- pkgrel = 5
+ pkgver = 2.1.0
+ pkgrel = 3
url = https://github.com/precice/fenics-adapter
arch = any
- license = LGPL3
- makedepends = openssh
+ license = LGPL-3.0-or-later
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-pyprecice
depends = python-dolfin
depends = python-scipy
- source = https://github.com/precice/fenics-adapter/archive/v1.3.0.tar.gz
- sha512sums = fb5a1b84c6e5cd66876a0c323881d16359d1e3e55eef054deba07c65a5a87148ee06fdb9a16eedda9120255cf161238767a1791b1994cf03ddb5943e22df00ff
+ source = fenics-adapter-2.1.0.tar.gz::https://github.com/precice/fenics-adapter/archive/v2.1.0.tar.gz
+ sha512sums = 71a814deac014f1c9f6e089e1e65c71053ad930b53c77074c0b158a267b0107979cbdc4bca6795d96d5a3e87d7a15afc7462ea807bf102bb5f3bcf428cf304d4
pkgname = python-fenicsprecice
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..852bf50e9c00
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-fenicsprecice]
+source = "github"
+github = "precice/fenics-adapter"
+use_latest_release = "true"
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index 44f96e7bab94..3bf915a585a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,31 @@
_base=fenicsprecice
pkgname=python-${_base}
pkgdesc="FEniCS-preCICE adapter is a preCICE adapter for the open source computing platform FEniCS"
-pkgver=1.3.0
-pkgrel=5
+pkgver=2.1.0
+pkgrel=3
arch=(any)
url="https://github.com/precice/${_base/precice/-adapter}"
-license=(LGPL3)
+license=(LGPL-3.0-or-later)
depends=(python-pyprecice python-dolfin python-scipy)
-makedepends=(openssh python-setuptools)
-source=(${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('fb5a1b84c6e5cd66876a0c323881d16359d1e3e55eef054deba07c65a5a87148ee06fdb9a16eedda9120255cf161238767a1791b1994cf03ddb5943e22df00ff')
+makedepends=(python-build python-installer python-setuptools python-wheel)
+checkdepends=(python-pytest)
+source=(${_base/precice/-adapter}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('71a814deac014f1c9f6e089e1e65c71053ad930b53c77074c0b158a267b0107979cbdc4bca6795d96d5a3e87d7a15afc7462ea807bf102bb5f3bcf428cf304d4')
build() {
- if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
- export OMPI_MCA_opal_warn_on_missing_libcuda=0
- fi
cd ${_base/precice/-adapter}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
cd ${_base/precice/-adapter}-${pkgver}
- python setup.py test -s tests.unit
- python setup.py test -s tests.integration
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
cd ${_base/precice/-adapter}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}