summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD11
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d129cbd7f75..469e20b5a07f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ffc-git
pkgdesc = A compiler for finite element variational forms.
- pkgver = 20201007
+ pkgver = 0.1.0.19.g4a4714ad
pkgrel = 1
url = https://github.com/FEniCS/ffcx
arch = any
@@ -17,4 +17,3 @@ pkgbase = python-ffc-git
md5sums = SKIP
pkgname = python-ffc-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..371760040d40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.pkg.tar.xz
+pkg
+src
+*\~
+*.bak
+*.tar.gz
+
+ffc
diff --git a/PKGBUILD b/PKGBUILD
index f31b257a214e..b74d1ea5162e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
-pkgname=python-ffc-git
+_base=ffc
+pkgname=python-${_base}-git
pkgdesc="A compiler for finite element variational forms."
-pkgver=20201007
+pkgver=0.1.0.19.g4a4714ad
pkgrel=1
arch=('any')
url="https://github.com/FEniCS/ffcx"
@@ -11,12 +12,12 @@ groups=('fenics-git')
depends=('python-dijitso-git' 'python-fiat-git' 'python-ufl-git' 'pybind11')
makedepends=('python-setuptools' 'git')
options=(!emptydirs)
-source=("ffc::git+https://github.com/FEniCS/ffcx.git")
+source=("${_base}::git+${url}.git")
md5sums=('SKIP')
pkgver() {
- cd ffc
- git log --format="%cd" --date=short -1 | sed 's/-//g'
+ cd "${srcdir}/${_base}"
+ git describe --tags --match '*.*' | tr '-' '.'
}
build() {