summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d2fc2dac8cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-fgivenx
+ pkgdesc = Python library for plotting Bayesian Functional Posteriors.
+ pkgver = 1.0.22
+ pkgrel = 1
+ url = https://github.com/williamjameshandley/fgivenx
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-joblib
+ depends = python-mpi4py
+ depends = python-tqdm
+ options = !emptydirs
+ source = https://github.com/williamjameshandley/fgivenx/archive/1.0.22.tar.gz
+ sha256sums = d674ffaef7e47fd6105a521f2e8f4ee6da61fe8d0bba5d2dd1aeb6739e8fc71a
+
+pkgname = python-fgivenx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8a14b1f91e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk>
+_modulename=fgivenx
+pkgname=python-$_modulename
+pkgver=1.0.22
+pkgrel=1
+pkgdesc="Python library for plotting Bayesian Functional Posteriors."
+arch=(any)
+url="https://github.com/williamjameshandley/fgivenx"
+license=('MIT')
+groups=()
+depends=('python-numpy' 'python-matplotlib' 'python-scipy' 'python-joblib' 'python-mpi4py' 'python-tqdm')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://github.com/williamjameshandley/fgivenx/archive/1.0.22.tar.gz')
+sha256sums=('d674ffaef7e47fd6105a521f2e8f4ee6da61fe8d0bba5d2dd1aeb6739e8fc71a')
+package() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+}