summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49ae9c590a63..a164e9985c91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Mar 26 13:48:02 UTC 2016
+# Sat Apr 15 13:38:23 UTC 2017
pkgbase = python-filterpy
pkgdesc = Kalman filtering and optimal estimation library in Python.
- pkgver = 0.1.2
- pkgrel = 2
+ pkgver = 0.1.5
+ pkgrel = 1
url = https://github.com/rlabbe/filterpy
arch = any
license = MIT
@@ -11,8 +11,10 @@ pkgbase = python-filterpy
makedepends = python-numpy
makedepends = python-scipy
makedepends = python-matplotlib
- source = https://github.com/rlabbe/filterpy/archive/0.1.2.tar.gz
- sha256sums = 42542b8a3e1792b4393ba0288cea2158ee922d029103b6cf8d52f3d11103554d
+ source = https://github.com/rlabbe/filterpy/archive/0.1.5.tar.gz
+ sha256sums = 13f083c0898f507a4725d1e026867089ff248fc8e736da6e74d00512ae65d008
pkgname = python-filterpy
+pkgname = python2-filterpy
+
diff --git a/PKGBUILD b/PKGBUILD
index 85400a1da833..197115c869fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
# Contributor: tuftedocelot <tuftedocelot@fastmail.fm>
-pkgname=python-filterpy
-pkgver=0.1.2
-pkgrel=2
+pkgname=('python-filterpy' 'python2-filterpy')
+pkgver=0.1.5
+pkgrel=1
pkgdesc='Kalman filtering and optimal estimation library in Python.'
arch=('any')
url='https://github.com/rlabbe/filterpy'
license=('MIT')
makedepends=('python-setuptools' 'python-numpy' 'python-scipy' 'python-matplotlib')
source=("https://github.com/rlabbe/filterpy/archive/$pkgver.tar.gz")
-sha256sums=('42542b8a3e1792b4393ba0288cea2158ee922d029103b6cf8d52f3d11103554d')
+sha256sums=('13f083c0898f507a4725d1e026867089ff248fc8e736da6e74d00512ae65d008')
-package() {
+package_python-filterpy() {
cd "$srcdir"/filterpy-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
}
+package_python2-filterpy() {
+ cd "$srcdir"/filterpy-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+}
# vim:set ts=2 sw=2 et: