summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31a89cc6a16f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-assertive
+ pkgdesc = Flake8 unittest assert method checker
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/jparise/flake8-assertive
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/jparise/flake8-assertive/archive/1.2.1.tar.gz
+ sha512sums = 908a1e3e4b2ef0cdfab1ebe04598b8802aa532247e8eabb7eed7ce775c4b790b4178533f86a17e49fbe0e53b090ac942ef4541130d09656f5ed1874106952e57
+
+pkgname = python-flake8-assertive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37708f1f31ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-assertive
+pkgname=python-$_pkgname
+
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Flake8 unittest assert method checker"
+
+url='https://github.com/jparise/flake8-assertive'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/jparise/$_pkgname/archive/$pkgver.tar.gz")
+sha512sums=('908a1e3e4b2ef0cdfab1ebe04598b8802aa532247e8eabb7eed7ce775c4b790b4178533f86a17e49fbe0e53b090ac942ef4541130d09656f5ed1874106952e57')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+