summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 855fe582c5a5..40d1e71333a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-flake8-simplify
pkgdesc = A flake8 plugin that helps you simplify your code.
- pkgver = 0.19.2
+ pkgver = 0.21.0
pkgrel = 1
url = https://github.com/MartinThoma/flake8-simplify/
arch = any
@@ -8,7 +8,7 @@ pkgbase = python-flake8-simplify
makedepends = python-installer
depends = flake8
depends = python-astor
- source = https://files.pythonhosted.org/packages/py3/f/flake8-simplify/flake8_simplify-0.19.2-py3-none-any.whl
- md5sums = ee1b98a55af98c1b4cf6158f14603338
+ source = https://files.pythonhosted.org/packages/py3/f/flake8-simplify/flake8_simplify-0.21.0-py3-none-any.whl
+ md5sums = 3081ce44a84c1b1c47ac89ad298bb201
pkgname = python-flake8-simplify
diff --git a/.gitignore b/.gitignore
index 9faefd41b2b1..5352fb8d769d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
/pkg/
/src/
/*.tar.gz
+/*.whl
/python-flake8-simplify-*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
index 52b474b6f465..cfdd5656b358 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Adrian Room <ingolemo@gmail.com>
-pkgname="python-flake8-simplify"
-_pkgname="flake8-simplify"
-pkgver=0.19.2
+_pkgname="flake8_simplify"
+pkgname="python-${_pkgname//_/-}"
+pkgver=0.21.0
pkgrel=1
pkgdesc="A flake8 plugin that helps you simplify your code."
arch=('any')
@@ -10,8 +10,8 @@ url="https://github.com/MartinThoma/flake8-simplify/"
license=('MIT')
depends=('flake8' 'python-astor')
makedepends=('python-installer')
-source=("https://files.pythonhosted.org/packages/py3/${_pkgname::1}/$_pkgname/${_pkgname//-/_}-$pkgver-py3-none-any.whl")
-md5sums=('ee1b98a55af98c1b4cf6158f14603338')
+source=("https://files.pythonhosted.org/packages/py3/${_pkgname::1}/${_pkgname//_/-}/${_pkgname}-$pkgver-py3-none-any.whl")
+md5sums=('3081ce44a84c1b1c47ac89ad298bb201')
package() {
python -m installer --destdir="$pkgdir" *.whl