summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1ddf6aae107..855fe582c5a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = python-flake8-simplify
pkgdesc = A flake8 plugin that helps you simplify your code.
- pkgver = 0.18.0
+ pkgver = 0.19.2
pkgrel = 1
url = https://github.com/MartinThoma/flake8-simplify/
arch = any
license = MIT
+ makedepends = python-installer
depends = flake8
depends = python-astor
- source = https://github.com/MartinThoma/flake8-simplify/archive/0.18.0.tar.gz
- md5sums = 06ebed3adc9ec3e2e087fde2e231ede7
+ source = https://files.pythonhosted.org/packages/py3/f/flake8-simplify/flake8_simplify-0.19.2-py3-none-any.whl
+ md5sums = ee1b98a55af98c1b4cf6158f14603338
pkgname = python-flake8-simplify
diff --git a/PKGBUILD b/PKGBUILD
index 3de54c2e7250..52b474b6f465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,17 @@
pkgname="python-flake8-simplify"
_pkgname="flake8-simplify"
-pkgver=0.18.0
+pkgver=0.19.2
pkgrel=1
pkgdesc="A flake8 plugin that helps you simplify your code."
arch=('any')
url="https://github.com/MartinThoma/flake8-simplify/"
license=('MIT')
depends=('flake8' 'python-astor')
-source=("https://github.com/MartinThoma/flake8-simplify/archive/$pkgver.tar.gz")
-md5sums=('06ebed3adc9ec3e2e087fde2e231ede7')
-
-build() {
- cd "${_pkgname}-${pkgver}"
- python setup.py build
-}
+makedepends=('python-installer')
+source=("https://files.pythonhosted.org/packages/py3/${_pkgname::1}/$_pkgname/${_pkgname//-/_}-$pkgver-py3-none-any.whl")
+md5sums=('ee1b98a55af98c1b4cf6158f14603338')
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" *.whl
}