summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore27
-rw-r--r--.gitignore_append1
-rw-r--r--PKGBUILD8
3 files changed, 32 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f12030797c07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..a92184e5a9bf
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1 @@
+# archlinuxpackages linux
diff --git a/PKGBUILD b/PKGBUILD
index 1f246a872f1c..7b37456bcda0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Serge Victor <arch@random.re>
_pipname=Flask-APScheduler
-_pkgname=flask-apscheduler
-pkgbase=python-$_pkgname
-pkgname=("python-$_pkgname" "python2-$_pkgname")
+_reponame=${_pipname,,}
+pkgbase=python-$_reponame
+pkgname=("python-$_reponame" "python2-$_reponame")
pkgver=1.11.0
pkgrel=2
pkgdesc='Adds APScheduler support to Flask'
arch=('any')
-url="https://github.com/viniciuschiele/$_pkgname"
+url="https://github.com/viniciuschiele/$_reponame"
license=('Apache')
makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools' 'python-apscheduler' 'python2-apscheduler' 'python-dateutil' 'python2-dateutil' 'python-flask' 'python2-flask')
source=("$url/releases/download/$pkgver/$_pipname-$pkgver.tar.gz"