summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 12 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3222f268d89..08751061664a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
# Generated by mksrcinfo(replacement shim) v8
-# Wed Aug 11 04:13:30 PM EDT 2021
+# Sat May 13 09:11:24 PM PDT 2023
pkgbase = python-flask1
pkgdesc = Micro webdevelopment framework for Python(1.x Branch)
pkgver = 1.1.4
- pkgrel = 2
+ pkgrel = 3
url = http://flask.pocoo.org/
arch = any
license = custom:BSD
- makedepends = python-setuptools
- makedepends = python-werkzeug
- makedepends = python-jinja
- makedepends = python-itsdangerous
- makedepends = python-click
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-werkzeug
depends = python-jinja
depends = python-itsdangerous
diff --git a/PKGBUILD b/PKGBUILD
index 36055f098841..dea5cdf95f0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=python-flask1
pkgver=1.1.4
-pkgrel=2
+pkgrel=3
pkgdesc='Micro webdevelopment framework for Python(1.x Branch)'
url='http://flask.pocoo.org/'
arch=('any')
@@ -15,26 +15,17 @@ license=('custom:BSD')
provides=("python-flask=1.1.4")
conflicts=("python-flask")
depends=('python-werkzeug' 'python-jinja' 'python-itsdangerous' 'python-click')
-makedepends=('python-setuptools' 'python-werkzeug'
- 'python-jinja' 'python-itsdangerous' 'python-click' 'python-pip')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::https://github.com/pallets/flask/archive/${pkgver}.tar.gz")
sha512sums=('e7ca33d599c0f7b83542620e827c999124ffe30e31006815b49993a81f9cf0d61dd0433b73f57f922da5aeb76101beccfe63d9a7236e1850e326f838dc1f453f')
-
build() {
- cd "flask-$pkgver"
- python setup.py build
-}
-
-check() {
- cd "flask-$pkgver"
- python setup.py test
+ cd "flask-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "flask-$pkgver"
-
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+ cd "flask-$pkgver"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
}
-