summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7164175ee8e6..29c14e9136b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = python-fontpens
- pkgdesc = A collection of classes implementing the pen protocol for manipulating glyphs.
+ pkgdesc = A collection of classes implementing the pen protocol for manipulating glyphs
pkgver = 0.2.4
- pkgrel = 3
- url = https://github.com/robotools/$_pyname
+ pkgrel = 4
+ url = https://github.com/robotools/fontPens
arch = any
license = BSD
checkdepends = python-fontparts
checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python-fonttools
source = https://files.pythonhosted.org/packages/source/f/fontPens/fontPens-0.2.4.zip
diff --git a/PKGBUILD b/PKGBUILD
index d33520ed3097..070afd686044 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,14 @@ BUILDENV+=(!check)
_pyname=fontPens
pkgname=python-${_pyname,,}
pkgver=0.2.4
-pkgrel=3
-pkgdesc='A collection of classes implementing the pen protocol for manipulating glyphs.'
+pkgrel=4
+pkgdesc='A collection of classes implementing the pen protocol for manipulating glyphs'
arch=(any)
-url='https://github.com/robotools/$_pyname'
+url="https://github.com/robotools/$_pyname"
license=(BSD)
depends=(python-fonttools)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
checkdepends=(python-fontparts
python-pytest)
_archive="$_pyname-$pkgver"
@@ -24,7 +25,7 @@ sha256sums=('a6d9a14573b3450f3313d69523f9006028c21fc7aef5d35333b87aab7f2b41fd')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
check() {
@@ -34,7 +35,7 @@ check() {
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt
}