summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e34d6be2f79..25b023b29559 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-fpdf2
pkgdesc = Simple PDF generation for Python
- pkgver = 2.7.7
+ pkgver = 2.7.8
pkgrel = 1
url = https://pyfpdf.github.io/fpdf2/
arch = any
- license = LGPL3
+ license = LGPL-3.0-only
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
@@ -13,8 +13,11 @@ pkgbase = python-fpdf2
depends = python-pillow
depends = python-defusedxml
depends = python-fonttools
+ optdepends = python-endesive: signing support
+ optdepends = python-uharfbuzz: text shaping support
+ optdepends = python-cryptography: encryption support
conflicts = python-fpdf
- source = https://files.pythonhosted.org/packages/source/f/fpdf2/fpdf2-2.7.7.tar.gz
- sha256sums = db1a2270c6f1d9d718d36f0862893c7844a2432f83ee77caa05770323ddc7fdd
+ source = https://files.pythonhosted.org/packages/source/f/fpdf2/fpdf2-2.7.8.tar.gz
+ sha256sums = 21733fe27cc75021e5a4d7d69de95e185adf9717b1f9b1e14aa27d277d5c10fd
pkgname = python-fpdf2
diff --git a/PKGBUILD b/PKGBUILD
index d9e1b2fc93d2..86432656119b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-fpdf2
_name=${pkgname#python-}
-pkgver=2.7.7
+pkgver=2.7.8
pkgrel=1
pkgdesc='Simple PDF generation for Python'
arch=(any)
url='https://pyfpdf.github.io/fpdf2/'
-license=(LGPL3)
+license=(LGPL-3.0-only)
conflicts=('python-fpdf')
-depends=('python' 'python-pillow' 'python-defusedxml' 'python-fonttools')
+depends=(python python-pillow python-defusedxml python-fonttools)
+optdepends=(
+ 'python-endesive: signing support'
+ 'python-uharfbuzz: text shaping support'
+ 'python-cryptography: encryption support'
+)
makedepends=(python-build python-installer python-setuptools python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('db1a2270c6f1d9d718d36f0862893c7844a2432f83ee77caa05770323ddc7fdd')
+sha256sums=('21733fe27cc75021e5a4d7d69de95e185adf9717b1f9b1e14aa27d277d5c10fd')
build() {
cd "$_name-$pkgver"