summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 50 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5838785e632f..7a81cc4a060c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,30 @@
pkgbase = python-frida
pkgdesc = Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 3 version from PyPi
- pkgver = 12.7.22
+ pkgver = 16.2.1
pkgrel = 1
url = https://www.frida.re
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = custom:wxWindows Library License, Version 3.1
depends = python
- depends = python-pygments>=2.0.2
- depends = python-colorama>=0.2.7
+ depends = python-setuptools
+ optdepends = python-typing_extensions: for Python <3.8
+ optdepends = rustup: for injecting Rust code into targets
conflicts = python2-frida
- source = https://files.pythonhosted.org/packages/source/f/frida/frida-12.7.22.tar.gz
+ noextract = frida-core-devkit-16.2.1-linux.tar.xz
+ source = https://files.pythonhosted.org/packages/source/f/frida/frida-16.2.1.tar.gz
source = COPYING
- sha256sums = b8a06bbac5f18b978f0a4154a72d29ceeb28b7c08840ea553d517d165c1526b3
+ sha256sums = 64a011825ea21a5ed3e3d7589f04c1dec473e1a083beb4c57895dddf32caa7c9
sha256sums = 5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2
+ source_i686 = frida-core-devkit-16.2.1-linux.tar.xz::https://github.com/frida/frida/releases/download/16.2.1/frida-core-devkit-16.2.1-linux-x86.tar.xz
+ sha256sums_i686 = 60a7bc73333fb3a31290705827b06e3d240aeb9991ebfdc28ca51909ccbcd275
+ source_x86_64 = frida-core-devkit-16.2.1-linux.tar.xz::https://github.com/frida/frida/releases/download/16.2.1/frida-core-devkit-16.2.1-linux-x86_64.tar.xz
+ sha256sums_x86_64 = ee2a6dc24f996bd0208d7d6b518b6f8bd45283cdb71d5f206bb1b4f40ea32265
+ source_armv7h = frida-core-devkit-16.2.1-linux.tar.xz::https://github.com/frida/frida/releases/download/16.2.1/frida-core-devkit-16.2.1-linux-armhf.tar.xz
+ sha256sums_armv7h = 4d8491ce055bb665f8dcb6a281f7b298517ca02cf5c86145b2a3179651de99fc
+ source_aarch64 = frida-core-devkit-16.2.1-linux.tar.xz::https://github.com/frida/frida/releases/download/16.2.1/frida-core-devkit-16.2.1-linux-arm64.tar.xz
+ sha256sums_aarch64 = 58815c55f1c4be0dfc14b38e3c2cdb9f0dfb810a0d85e5d8ecca3a89f541de03
pkgname = python-frida
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d7c7884c7c7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+frida-*
+python-frida-*
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index cfb58975bd8f..ef63693c250e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,49 @@
+# Maintainer: kriskras99 <admin at kriskras99 dot nl>
+# Contributor: Ali Molaei <ali dot molaei at protonmail dot com>
+# Contributor: algebro <algebro at tuta dot io>
+
_pkgname=frida
pkgname=python-$_pkgname
-pkgver=12.7.22
+pkgver=16.2.1
pkgrel=1
pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 3 version from PyPi"
-arch=('i686' 'x86_64') # setup.py downloads pre-built binary components, so it doesn't work on ARM (yet).
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.frida.re"
license=('custom:wxWindows Library License, Version 3.1')
-depends=('python' 'python-pygments>=2.0.2' 'python-colorama>=0.2.7')
+depends=('python'
+ 'python-setuptools')
+optdepends=('python-typing_extensions: for Python <3.8'
+ 'rustup: for injecting Rust code into targets')
+# Sourced from https://pypi.org/project/frida/#files
source=("https://files.pythonhosted.org/packages/source/f/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
"COPYING")
-sha256sums=('b8a06bbac5f18b978f0a4154a72d29ceeb28b7c08840ea553d517d165c1526b3'
+# Sourced from https://github.com/frida/frida/releases
+source_i686=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-x86.tar.xz")
+source_x86_64=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-x86_64.tar.xz")
+source_armv7h=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-armhf.tar.xz")
+source_aarch64=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-arm64.tar.xz")
+sha256sums=('64a011825ea21a5ed3e3d7589f04c1dec473e1a083beb4c57895dddf32caa7c9'
'5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2')
+sha256sums_i686=('60a7bc73333fb3a31290705827b06e3d240aeb9991ebfdc28ca51909ccbcd275')
+sha256sums_x86_64=('ee2a6dc24f996bd0208d7d6b518b6f8bd45283cdb71d5f206bb1b4f40ea32265')
+sha256sums_armv7h=('4d8491ce055bb665f8dcb6a281f7b298517ca02cf5c86145b2a3179651de99fc')
+sha256sums_aarch64=('58815c55f1c4be0dfc14b38e3c2cdb9f0dfb810a0d85e5d8ecca3a89f541de03')
+noextract=("frida-core-devkit-${pkgver}-linux.tar.xz")
conflicts=("python2-${_pkgname}")
+prepare() {
+ mkdir "$srcdir/frida-core-devkit-${pkgver}-linux"
+ bsdtar -x --cd "$srcdir/frida-core-devkit-${pkgver}-linux" -f "frida-core-devkit-${pkgver}-linux.tar.xz"
+}
+
build() {
cd "$srcdir/$_pkgname-$pkgver"
- python setup.py build
+ FRIDA_CORE_DEVKIT="../frida-core-devkit-${pkgver}-linux" python setup.py build
}
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
+ FRIDA_CORE_DEVKIT="../frida-core-devkit-${pkgver}-linux" python setup.py install --root=$pkgdir --optimize=1 --skip-build
cd "$srcdir"
install -d "$pkgdir/usr/share/licenses/$pkgname"