summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dea6cf440cff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jul 7 01:51:25 UTC 2016
+pkgbase = python-gantt
+ pkgdesc = Python-Gantt make possible to easily draw gantt charts from Python. Output format is SVG.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://xael.org/pages/python-gantt-en.html
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-svgwrite
+ depends = python-dateutil
+ source = http://xael.org/pages/python-gantt-0.6.0.tar.gz
+ md5sums = 4c94fede2f314e4735b2a69a84bdcca6
+
+pkgname = python-gantt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6803660e373a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src
+/pkg
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58b3d8be5e42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Anselmo L. S. Melo <anselmolsm@gmail.com>
+_pkgname=gantt
+pkgname=python-$_pkgname
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Python-Gantt make possible to easily draw gantt charts from Python. Output format is SVG."
+arch=('any')
+url="http://xael.org/pages/python-gantt-en.html"
+license=('GPL3')
+depends=('python' 'python-svgwrite' 'python-dateutil')
+optional=('python-clize')
+source=('http://xael.org/pages/python-gantt-0.6.0.tar.gz')
+md5sums=('4c94fede2f314e4735b2a69a84bdcca6')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+}
+
+# vim:set sw=2 et: