summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7628984e19f7..f6214b83a88f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-gaphas-git
pkgdesc = Diagramming widget library for Python
- pkgver = 3.5.0.r0.ga51f017
+ pkgver = 3.6.0.r3.gf012089
pkgrel = 1
url = https://github.com/gaphor/gaphas
arch = x86_64
arch = i686
license = Apache
checkdepends = python-pytest
+ checkdepends = xorg-server-xvfb
makedepends = git
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index 3385c5834177..1175da865328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
-# Contributor: Padraic Fanning <fanninpm AT miamioh DOT edu>
+# Maintainer: Padraic Fanning <fanninpm AT miamioh DOT edu>
_pkgname=python-gaphas
pkgname="${_pkgname}-git"
@@ -26,7 +26,10 @@ makedepends=(
)
optdepends=(
)
-checkdepends=('python-pytest')
+checkdepends=(
+ 'python-pytest'
+ 'xorg-server-xvfb'
+)
provides=(
"${_pkgname}"
)
@@ -44,7 +47,7 @@ build() {
check() {
cd "${srcdir}/${_pkgname}"
- pytest
+ xvfb-run --auto-servernum pytest
}
pkgver() {