summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e100f97e53a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-gbulb
+ pkgdesc = Implmementation of asyncio using GLib
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/nathan-hoad/gbulb
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-gobject
+ optdepends = gtk3: Gtk application integration
+ source = https://github.com/nathan-hoad/gbulb/archive/0.4.tar.gz
+ sha256sums = 91b60a05da3197e537525224f88ba23d951b9175a6a33d6d4565e492ab591c35
+
+pkgname = python-gbulb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa3638b6466d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Patrick Griffis <tingpign@tingpng.se
+
+_modname='gbulb'
+pkgname='python-gbulb'
+pkgver=0.4
+pkgrel=1
+pkgdesc='Implmementation of asyncio using GLib'
+arch=('any')
+url='https://github.com/nathan-hoad/gbulb'
+license=('Apache')
+makedepends=('python-setuptools')
+depends=('python-gobject')
+optdepends=('gtk3: Gtk application integration')
+source=("https://github.com/nathan-hoad/gbulb/archive/$pkgver.tar.gz")
+sha256sums=('91b60a05da3197e537525224f88ba23d951b9175a6a33d6d4565e492ab591c35')
+
+package() {
+ cd "$_modname-$pkgver"
+
+ python ./setup.py install --prefix=/usr --root="$pkgdir" --optimize=2
+}