summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c7ba81453c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-gdax
+ pkgdesc = The unofficial Python client for the GDAX API
+ pkgver = r2.7a3f1e0
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python>=3.5
+ depends = python-bintrees>=2.0
+ depends = python-requests>=2.13
+ depends = python-six>=1.10
+ depends = python-websocket-client>0.40
+ provides = python-gdax
+ source = python-gdax::git+https://github.com/acontry/GDAX-Python.git
+ md5sums = SKIP
+
+pkgname = python-gdax
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e54d2b09bcc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: vsilv vsilv@posteo.eu
+
+pkgname=python-gdax
+pkgver=r2.7a3f1e0
+pkgrel=1
+pkgdesc="The unofficial Python client for the GDAX API "
+arch=('x86_64')
+license=('MIT')
+depends=('python>=3.5' 'python-bintrees>=2.0' 'python-requests>=2.13' 'python-six>=1.10' 'python-websocket-client>0.40')
+makedepends=('git')
+provides=('python-gdax')
+_gitname='python-gdax'
+source=(${_gitname}'::git+https://github.com/acontry/GDAX-Python.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --prefix=/usr --root=${pkgdir} -O1 --skip-build
+}
+