summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD20
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2194d38246e5..1163caa0314b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gdl
pkgdesc = Python interface for the GNU Data Language(GDL)
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
url = http://gnudatalanguage.sourceforge.net
arch = i686
@@ -8,13 +8,13 @@ pkgbase = python-gdl
license = GPL
makedepends = cmake
makedepends = eigen
- depends = gnudatalanguage=1.0.2
+ depends = gnudatalanguage=1.0.3
depends = python-numpy
conflicts = python2-gdl
- source = https://github.com/gnudatalanguage/gdl/archive/v1.0.2.tar.gz
+ source = python-gdl-1.0.3.tar.gz::https://github.com/gnudatalanguage/gdl/releases/download/v1.0.3/gdl-v1.0.3.tar.gz
source = gdl.profile
source = gdl-1.0.1-fix-python-wxGetApp.patch
- md5sums = 0a86735911637bcdb6935ee6cd14d751
+ md5sums = 8125987275e4bcea3736c51603427e9b
md5sums = 40aa5fd8278cd8e80425c62a577563cc
md5sums = bf1e1fb364eaf92e09ad7031c0c2b546
diff --git a/.gitignore b/.gitignore
index 6659f11dfb07..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,9 +1,8 @@
-!.gitignore
-!gdl.profile
-!gdl-python3.patch
-!gdl-graphicsmagick.patch
-!gdl-mallinfo2.patch
-!gdl-tiff.patch
-!PKGBUILD
-!.SRCINFO
-*tar*
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 20fd7cfd7224..220befd8ccfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Jan Kohnert <kohni.jk at gmail dot com>
pkgname=python-gdl
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="Python interface for the GNU Data Language(GDL)"
arch=('i686' 'x86_64')
@@ -15,10 +15,10 @@ depends=("gnudatalanguage=${pkgver}" 'python-numpy')
makedepends=('cmake' 'eigen')
#options=('!makeflags')
conflicts=('python2-gdl')
-source=("https://github.com/gnudatalanguage/gdl/archive/v${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gnudatalanguage/gdl/releases/download/v${pkgver}/gdl-v${pkgver}.tar.gz"
'gdl.profile'
'gdl-1.0.1-fix-python-wxGetApp.patch')
-md5sums=('0a86735911637bcdb6935ee6cd14d751'
+md5sums=('8125987275e4bcea3736c51603427e9b'
'40aa5fd8278cd8e80425c62a577563cc'
'bf1e1fb364eaf92e09ad7031c0c2b546')
@@ -27,14 +27,14 @@ get_pyinfo() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
}
-prepare() {
- cd ${srcdir}/gdl-${pkgver}
-
- patch -Np1 -i "${srcdir}/gdl-1.0.1-fix-python-wxGetApp.patch"
-}
+#prepare() {
+# cd ${srcdir}/gdl-${pkgver}
+#
+# patch -Np1 -i "${srcdir}/gdl-1.0.1-fix-python-wxGetApp.patch"
+#}
build() {
- cd ${srcdir}/gdl-${pkgver}
+ cd ${srcdir}/gdl
if [[ -d build ]]; then
rm -r build
fi
@@ -50,7 +50,7 @@ build() {
}
package() {
- cd ${srcdir}/gdl-${pkgver}/build
+ cd ${srcdir}/gdl/build
if [[ -d ../pkginstall ]]; then
rm -r ../pkginstall
fi